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Client Certificate Guide

Client Certificate Guide

This is a step-by-step introduction in how to create a client-certificate keystore in Java environment. In
this document we use KeyStore explorer software that is free and available for download for several
operating systems.

1 Basic Setup

Download and install free KeyStore Explorer software from
https://keystore-explorer.org/

KeyStore Explorer is far more user-friendly that Java’s command line Keytool.

2 Generating Private Key and Keystore

Open KeyStore Explorer and select “Create a new KeyStore” (or File->New).
New KeyStore Type should be JKS.

- KeyStore Explorer 5.4.1 - O x
File Edit View Tools Examine Help
[] New CtrlsN plap@|e
L Open Ctrl+0
(& Open Special >

Close Chrl+W

Close All Ctrl+ Shift+ W

Save Ctrl+S

Save As Ctrl+Alt+S

Save Al ClrleShiftsS KeyStqre Explorer

Quick Start
|e| Recent Files >
I et Alt+Fd | | = i
Create a Open an Open the
new KeyStore existing KeyStore  Default KeyStore
Lol —% 0

Open the CA Examine a Show the
Certificates KeyStore Certificate Help Pages

Create a new KeyStore

Generate a new key pair. This selection is available if you right-click the window or from the Tools menu
(in version 5.4). Use the default values (Algorithm: RSA, Key Size: 2048).


https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fkeystore-explorer.org%2F&data=05%7C01%7Ckimmo.simola%40ruokavirasto.fi%7C152ef51269ee49330e4e08dad141f221%7C7c14dfa4c0fc47259f0476a443deb095%7C0%7C0%7C638052378398441535%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=7fWT0DR7hDZBa2loMVXly3zHzXHBI0Mm5GK26KyISm8%3D&reserved=0
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Generate Key Pair Certificate X

Version: () Version 1 (@) Version 3

Generate Key Pair *
Signature Algorithm: | SHA-256 with RSA ~
Algorithm Selection Validity Start: | 18.11.2019 12:26:44 EET B
@ ..R..SA‘ Key Size: 204815 validity Perind: 255 |Year(s) Apply
() DsA Key Size: 2048 = Validity End: | 17.11.2020 12:26:44 EET 54
O EC set: |ANSLX9.62 Serial Mumber: | 1574072804

Name:

Mamed Curve: |[c2inb191w1
Add Extensions

Cancel ox Cance

Select the following values from the next dialog:
e Version: Version 3
e Signature Algorithm: SHA-256 with RSA
e Validity Period: 2
e Click the button next to Name to open another dialog.

Name X

~
Common MName (CN): « | |MyOrg_name_1 + -
Qrganization Unit (OU):  ~+ | |MyOrg unit name + -
Organization Name (O):  ~ | MyOrganization + -
Locality Name (L): | |Helsinki + -
State Name (ST): ~ | |Uusimaa + -
Country (C): v | |F] + -

v

Reset

o

Fill in the details. Common Name (CN) should be distinguishable among all other certificates (in Finland).
Use only ASCII characters in all fields.

Click OK, then OK again.
KeyStore Explorer suggests an alias for the key pair, leave it unmodified.
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Mew Key Pair Entry Password X
Mew Key Pair Entry Alias .
= Y Enter Mew Password: |sssssssss
Enter Alias: Confirm New Password: | sessssssa|

Cancel Cancel

Enter password for private key and store it in a safe place! You will need this password later and if you
lose it, your private key is unusable. This password protects your private key and you must not give it or
send it to any outside partner in any case.

Save your Keystore using File->Save. You'll be asked for password for keystore file itself. This password
should be the same as your key pair's password from last step. It can also be different, but to make sure
that your Java implementation is able to use keystore file and key pair properly, use same password.
Store password in safe place!

Enter a name for your keystore and use file extension .jks

v 4 B > Tykansiot > projektit » Testi

Jarjesta = Uusi kansio

B Tama tietokone - Tila Muckkauspéiva Tyyp

Hakuehtoja tayttavia kohteita ei 6y

Ladatut tiedost
Musiikki
E Tiedostot
M Tyopoyta
deot

Tiedostonimi: I"-a"I'_-,rli]rg._iks

Muoto: | All Files (%)

~ Piilota kansiot

Now you have a Java Keystore containing a private key. Next we need to acquire a signed certificate.
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3 Certificate Signing Request

Next thing we need is a signed client certificate. We start by creating a certificate request using your
private key. This will be then signed by the certificate authority.

Right-click your private key and select -Generate CSR’ from the context menu.

MyOrg.jks - KeyStore Explorer 5.4.1 - m] s
Eile Edit View Toels Examine Help
NEd e~ XDBRLAR—O|AEE O
MyOrg.jks %

T |8 [E| EntryMame Algorithm Key Size Certificate Expiry Last Modified

(77 | o | ~ prors.remet T I T R T
o »
%

View Details

Cut Ctrl+X
Copy Ctr+C

[ ¢

Export ¥
Generate CSR

Import CA Reply >
Edit Certificate Chain ?

§ e [o) i+

# Sign >

Unlock
Set Password
Delete

T

Rename

Generate a Certificate Signing Request (CSR) for the Key Pair entry as PKCS #10 or SPKAC
¥

Use the following values:
e PKSC#10
e Signature Algorithm: SHA-256 with RSA
e Challenge: empty
e CSR File: name ending in _request followed by a number if you’re creating multiple requests

from multiple private keys. File extension .csr
Generate CSR *

Format:

Signature Algorithm: | SHA-256 with RSA "
Distinguished Mame (DN) |CN=MyCra_name_1,0U=MyCrg unit name,0=MyOrganization,L=| Igﬁ B
Challenge:
Optional Company Mame:
Extensions: [ | Add certificate extensions to request

CSR File:  |\Wsers\03073143\Work Folders\projektitiTestiYmyorg_name_1.csr Browse

==
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Now you have created the certificate signing request using your private key. Send the file
(myorg_name_1 request.csr) to the designated contact person along with user rights application. Never
send your keystore file or any password to anyone!

4 Combining Signed Certificate with Private Key

After receiving the signed certificate from the certificate authority you must combine it with your
private key. The certificate may have one of several file extensions, for example: .cer, .p7r, .pem or .der.

The Finnish Food Authority supplies a .cer file along with two CA certificates.

Open the Keystore, right-click the private key and select ‘Import CA Reply’ from the context menu.

- MyOrg.jks - KeyStore Explorer 5.4.1

Eile Edit View Tools Examine Help

DEHeas OB RLAR~O|CEE|O
MyOrg.ks %

T |@ |E EntryName Algorithm

(77 [ & |~ prorsrene_i_
. 8

View Details

#a Cut Ctrl+X

] Copy Ctrl+C

& Export >

I Generate CSR

¥ Import CA Reply 4 [-| FromFile
&5 Edit Certificate Chain ] |:| From Clipboard
~# Sign >

Unlock

w1 Set Password

K Delete

T° Rename

KeyStore Type: JKS, Size: 1entry , Path: 'C:\Users\03073143\Work Folders\projektitiTestiMyOrg. jks'

Key Size

Certificate Expiry

Last Modified

. [Rsa [e48 (17112020 12:26:44 EET 18.11.2019 12:40:09 EET
»

Select the signed certificate (myorg_name_1_request.cer) and click ok.

KeyStore Explorer will confirm that the import was successful. This does not indicate that the certificate

chain is in order and it should be checked.

Import CA Reply X

CA Reply lmport Successful,
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Open the context menu once again by right-clicking the key. Select View Details -> Certificate Chain

Details.

/- MyOrg,jks * - KeyStore Explorer 5.4.1
File Edit View Tools Examine Help

NEH e+ X B RLRARTA—O|AEEQ|6

MyOrg.jks * %

T @ [E EniryName

77 e ] e

View Details

Export

Generate CSR.
Import CA Reply
Edit Certificate Chain

remp FX B

T
R

Sign

Unlock

:l‘

Set Password
Delete

T »

Rename

Display details of the Key Pair entry’s certificate chain

Cut Ctrl+X
Copy Ctrl+C

Algorithm Key Size
lbea ______ lonas
> @ Certificate Chain Details
' Private Key Details
‘7 Public Key Details

Certificate Expiry
122.11,2021 10:29:37 EET

Last Modified
120.11.2019 11:44:39 EET

If the Certificate Hierarchy tree contains only the newly acquired certificate, you need to construct the

certificate chain by hand.

Serial Number: | 0x2591F1E7C

Fingerprint: |SHA-1

Issuer: |E=administrator@mmm.fi, CN=MMM TESTI Intermediate CA 2018,C

=0

Valid From: | 20,11.2019 10:29:37 EET
Valid Until: |22.11.2021 10:29:37 EET
Public Key: |RSA 2048 bits

Signature Algorithm: | SHA256WITHRSA

Export Extensions PEM

Certificate Details for Entry 'myorg_name_1' X
Certificate Hierarchy:
Version: |3
Subject: | O=MyOrganization,OU=MyQOrg unit name,C=FI,CN=MyOrg_name, E_ﬁ

| |BB:1A:12:92:02:02:99:32:26: 11:64:E4:94:9A: 3E: @

ASM.1




Tr@ H RUOKAVIRASTO Page/pages s

Livsmedelsverket ® Finnish Food Authority Guide/version

Valid from
Client Certificate Guide
From the context menu, select Edit Certificate Chain -> Append Certificate.
J - MyCOrg.jks * - KeyStore Explorer 5.4.1 - O x
File Edit View Tools Examine Help
NEmar 0B RLRA—O|AEQ|O
MyOrg.jks * %
T & |E EntryMame Algorithm Key Size Certificate Expiry Last Modified
T e —— N S ¥ ¥ NV T F TR
—,  View Details y
#8 Cut Ctrl+X
U9 Copy Ctrl+C
2 Export ¥
I| Generate CSR
¥ Import CA Reply b
== Edit Certificate Chain > ﬁ. Append Certificate
= sign :ﬁ Remowve Certificate
Unlock
]  Set Password
7 Delete
T Rename

Append a certificate to the end of the Key Pair entry's certificate chain

Choose the intermediate certificate (mmm_intermediate_ca_2018.cer) first. Confirmation will be
displayed. Then repeat the procedure for the root certificate (mmm_root_ca_2018.cer).

Tila Ssiv Tyyppi

10.1.2018 13.29 Suojausvarmenne

Append Certificate >

s 4

6kohdetta | 1kohde valittu: 248kt | Synkronointi odottaa | Synkronoinnin tila: % Tiedostoj ynkronoida. Lisatietoja... | (§ B
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Now the Certificate Hierarchy should display two parent certificates (test certificates shown). This does
not guarantee that any software using the keystore trusts the issuer certificates. You may need to add
these certificates to a separate trust store. In any case our keystore now contains information about the

certificate’s issuers.
Certificate Details for Entry 'myorg_name_1' *

Certificate Hierarchy:

[ Y TESTT Root A 2018

Bﬁ MMM TESTI Intermediate CA 2013
ﬁ MyOrg_name_1

Version: |3
Subject: |E=administrator @mmm. fi, CN=MMM TESTI Root CA 2018,0U =Tietc IEt
Issuer: | E=administrator @mmm. fi, CN=MMM TESTI Root CA 2018,0U=Tiet Ist
Serial Number: | 0x2EE90041
Valid From: |11.1.2018 12:24:39 EET
Valid Until: |11.1.2028 12:24:39 EET
Public Key: |RSA 4096 bits T
Signature Algorithm: | SHAZ256WITHRSA
Fingerprint: | SHA-1 ~ | |AF:62:48:72: 24:6C:98: 26:B5: CA:F7:5A:C0:DE: 4« @

Export Extensions PEM ASN.1

5 Exporting key pair to PKCS12 (.p12) format

If you need to have the key pair (private key and signed certificate) as Windows friendly pkcs12-format,
it can be done with Keystore Explorer by following steps

Right click key entry in Keystore Explorer. Choose Export -> Export Key pair. Enter password for private
key from earlier.

- MyOrg.jks - KeyStore Explorer 5.4.1 - u] X

File Edit View Tools Examine Help
JEH a2 X0BRLRE~0/AEQ|O

MyOrg.jks ¥
T @ [E EntryName Algorithm Key Size Certificate Expiry Last Modified
Invrs e | RN |5

o7 Lsi | = mjors_name_L GRS 5 poss |

# Cut Ctrl+X

[ copy Ctrl+C

2 Export » G Export Key Pair

|| Generate CSR #  Export Certificate Chain

2 Import CAReply i 1 Export Private Key

=5 Edit Centificate Chain 1T Export Public Key

7 Sign >

Unlock

= Set Password

X  Delete

T2 Rename

KeyStors Type: JGS, Size: 1 entry , Path: 'C:\Users\D3073143\Work Folders\projekaitiTest\Myorg.jke'
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Enter new passwords for pkcs12 file. Filename extension is p12.

Export Key Pair from KeyStore Entry 'myorg_name_1' x

Format: (@) PKCS#12 () PEM
Password for Qutput File: (essssssss
Confirm Password:  sssssssss]

ExportFile: | \Work Folders'projektitiTesti\myorg_name_1.p12 Browse

Caree

You'll be notified if exporting was successful.

Export Key Pair -

Export Key Pair Successful,

Now you have a file named myorg_name_1.p12. It contains key pair in pkcs12-format. It can be installed
to Windows' certificate management by opening the file and following the instructions.
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